Blogs, Articles & Videos

At Big Red SEO we believe in educating our clients and potential clients as much as possible. We update our blog regularly with things we’re seeing in the industry, tips for website exposure, security alerts and general business. If you have an idea for a blog post you want us to cover, please contact us!

View a Single Article Category / Type
WordPress Elementor Plugin Exploit 2020

Elementor Versions 2.8.5 and Below

Popular WordPress plugin, Elementor, has a severe exploit that could affect more than 4 million websites. The exploit affects all versions prior to 2.8.5. Users are encouraged to update their plugins ASAP.

Read More »
WooCommerce 3.5 and WordPress 5.0

WooCommerce? Read This Before WordPress 5.0 Release

If you’ve been keeping up with the new WordPress 5.0 version, scheduled for release on November 19th 2018, you’ll know there are a ton of changes. One massive change is how it integrates with WooCommerce. The integration is a full rewrite of code and if you upgrade WordPress and fail to update WooCommerce ahead of

Read More »
WordPress Update and Management in Omaha

First WordPress Update of 2018 – Version 4.9.2

On January 16th, 2018, WordPress pushed out their latest update for their software.  For most people, this means they have upgraded to 4.9.2 automatically, but because this was a security update, anyone using older versions of WordPress also received some form of an update! What’s In The New Update? In short, not much.  This was

Read More »

WordPress Security Update Released – Version 4.7.3

Earlier today, WordPress released a new update to take care of some security issues. If you’re running WordPress on your website, and have auto-update enabled, then your site will update today March 6th, 2017. If you have the automatic updates turned off, it’s recommended to make the update as there are some potential security issues

Read More »

PHPMailer Security Vulnerability – Affects WordPress

I hope you enjoyed the Christmas Holidays because we’re right back into software security and vulnerability issues. This week, we’re looking at PHPMailer 5.2.18 and lower. LegalHackers released an announcement on Christmas Day that a new vulnerability has been discovered in PHPMailer 5.2.18, and as a result, the WordPress Core software. You can read the

Read More »
Google-Analytics-Traffic-Dropped-in-February-2016---Don’t-Panic-yet!

W3 Total Cache Plugin – XSS Vulnerability 9/23/2016

W3 Total Cache is an optimization plugin for WordPress which will cache pages and posts and speed up the website. On September 23rd, 2016 it was announced a new Cross Site Scripting vulnerability, commonly known as an “XSS Vulnerability.” As of 8 pm CDT on September 23rd, 2016, there is no fix/patch available. Your only

Read More »
Business-Owners-Frustrated-with-Google-Search-Engine-Rankings-and-Drop

Yahoo Hacked – Another Big Data Breach

Hacked websites happen on a regular basis, and it seems as if every couple of weeks we see another news alert about the latest “largest data breach ever” being perpetrated by a group of unknown persons. September 2016 is a month like any other, with various alerts and warnings, however, Yahoo! has just announced a

Read More »